OSPF คืออะไร

วันนี้มาอธิบายง่ายๆเพื่อให้ท่านที่อ่านนั้นเข้าใจได้รวดเร็วเกี่ยวกับ OSPF คืออะไร ทำไมเกี๋ยวนี้เขานิยมพูดถึงกันมากแต่ดูเหมือนระบบของเรายังห่างไกลเหลือเกิน และจะมีวิธีผระยุกต์Mikrotik กีบ OSPF อย่างไรในระบบของแต่ละท่านกันครับ ผมขอเขียนอธิบายเฉพาะเนื้อหา ยังไม่ลงถึงวิธีการตั้งค่าครับ ถ้ามีโอกาสหน้าแวะมาติดตามที่นี่ได้

OSPF คือ Dynamic Routing Protocol แน่นอนว่าหลายท่านคงยังห่างกับคำว่า Routing พอสมควรเพราะเนื่องจากระบบส่วนใหญ่ยังไม่ซับซ้อนและไม่มีความจำเป็นที่ต้องใช้ครับ ให้นึกภาพว่า ท่านอยู่ในบ้าน เวลาท่านจะขับรถออกนอกบ้าน ท่านก็มีประตูเดียวใช่ไหมครับ เรื่องนี้ก็เหมือนกัน

สำหรับองค์กรที่ใช้ OSPF นั้น ส่วนใหญ่จะเป็นระบบที่ซับซ้อนมากๆ ก็เหมือนผมยกตัวอย่างว่า ท่านจะออกจากบ้าน แต่บ้านท่านมีประตูเชื่อมกับบ้านอื่นๆเป็นร้อยหลัง แล้วจะรู้ได้อย่างไรว่าประตูไหนมันผ่านได้ ประตูไหนปิดตาย และถ้าจะไปหาบ้านผู้ใหญ่จะเดินผ่านประตูบ้านใครได้บ้าง เริ่มน่าคิดแล้วใช่ไหมครับ ระบบใหญ่ๆก็เป็นลักษณะนี้เหมือนกัน ดะงนั้นเร้าเตอร์ก้ต้องมีฐานข้อมูลที่ใช้เก็บเส้นทาง ซึ่งเรียกว่า routing table นั่นเอง

ดังนั้น OSPF จึงถูกใช้กับ Router/Layer3 Switch ที่ถือ network หลายวงอยู่ในเครื่องเดียวอยู่ ผมขอยกตัวอย่าง สเกลระบบมหาวิทยาลัยขนาดใหญ่ครับ ว่ามันสามารถช่วยให้ แอดมินอย่างเราทำงานง่ายขึนอย่างไร

ในมหาลัยแห่งหนึ่ง จะมี Routerตัวใหญ่ ที่ทำหน้าที่เป็นศก.ให้กับระบบและเป็นประตูทางออกสู่โลกภายนอก อยู่หนึ่งเครื่อง สมมุติว่าไอพี 1.1.1.1 มือถือคอมจะต้องผ่านไอพีนี้ก่อนถึงออกไปจ๊ะเอ๋กับภายนอกได้

และเมื่อแยกย่อย จะมี router เล็กๆ แต่ละคณะภาควิชาละ 1 ตัว ซึ่งต่อจากตรงนี้ก็จะมี ไอพีภายในอีกหลายวงที่ใช้แจกจ่ายให้กับนักศึกษาในตึกนั้นได้ใช้ครับ

และมหาลัยไม่ได้มี แค่ router เครื่องเดียว วงแลนวงเดียว แต่มีเป็นร้อยวง ซึ่งแอดมินก็ต้องชี้เส้นทางใฟ้เองว่า ถ้าเอ็งจะไปตึกศิลป์ เอ็งจะต้องผ่าน เร้าเตอรเบอร์ 2.2.2.2 ก่อนถึงจะเข้าสู่ตึกศิลป์ได้ เพิ่มใน routing table ของทุกตัวในมหาลัย งานช้างละสิ ใครจะมีเวลานั่งว่าง ชี้เส้นทางให้เร้าเตอร์ทุกคนไปตึกศิลป์ได้ และถาสมมุติ เส้นทางระหว่าง 2.2.2.2 เสียละ ต้องแล่แก้ใหม่หมด คงสนุกแน่ๆ

เรียกระบบนี้ว่า static route แอดมินต้องเพิ่มด้วยมือทุกเครื่องเอง

ospf จึงเข้ามาช่วยในการแก้ปัญหานี้ไงครับ ฌดยให้ เร้าเตอร์แต่ละตัวประกาศตัวเองออกมา ผมนายa มีเน็ตเวิค 2.2.2.0/xx ถ้าจะเข้ามาใช้ให้ผ่าน นายb นาย cก่อนครับ

และเมื่อหลายๆเร้าเตอร์ต่างประกาศ กันอย่างว้าวุ่น ข้อมูลคงอัดเต็มสายแน่ๆ ดังนั้นเขาก็เลย แบ่งโซน ออกมาหลายๆโซน เรียกว่า area ซึ่งต้องขึเนอยุ่กับแอดมินว่า จะจัดให้อยุ่โซนไหน แนะนำคือ ถ้าผ่านเส้นทางเดียวกัน หลายๆทอดก้จัดให้อยู่ area เดียวกัน เวลาจะคุยกับเร้าเตอร์ใกล้ก้คุยได้เลยจะไม่ให้ไปรบกวน area อื่น และจะมี router ตัวแทนที่จะทำหน้าที่คุยกับ area อื่น เรียกว่า border area ครับ

เสียงในตลาดสดก็เงียบลงไปเยอะ

และการหาเส้นทางว่าวิ่งผ่านอะไรได้บ้าง ก้มาจากชื่อย่อเลยครับ ซึ่งมันจะใช้ระยะทางที่ใกล้ที่สุด และ มี cost น้อยที่สุด เป็นทางที่จะไป สรุปว่า มันเลือกทางที่ดีให้อัตโนมัติเอง ถ้าอยากลงลึก ใหห้ไปหาข้อมูลเองครับ

ospf เป็น dyn routing ที่ใช้ข้างในนะครับ ถ้าข้างนอกจะเป็นพวก BGP แล้ว ไว้ผมมีโอกาสจะมาเล่าให้ฟังอีก จึงเห็นได้ว่า คนส่วนใหญ่มักใช้ ospf วิ่งผ่าน tunnel vpn ต่างๆ เพื่อที่จะเข้าไป access ที่ต่างๆได้ง่ายขึ้น

สมมุติผมรับติดตั้งระบบ hotspot ให้กับหอพักทั่วไทย ผมมี router mikrotik อยู่เป็นร้อยเครื่อง จัดการยากแล้วใช่ไหม ดังนั้นถ้าผม จะเข้าไปหาเร้าเตอร์นั้น ซึ่งมีไอพีจริงเปลี่ยนตลอด หรือบางที่ก้ไม่มีให้ รีโมืก้ยาก ผมเลยทำการตั้ง vpn server กลางของผม และให้เร้าเตอร์ทุกตัวที้ผมวางระบบ เชื่อมต่อ vpn มาหา พร้อมกับรัน ospf ไปด้วยทุกตัว ทำให้ผมสามารถไปที่ไหนก้ได้ในระบบผมแล้ว เมื่เปลี่ยนเส้นทางก้ง่ายอีก ospf มีนฉลาดเปลี่ยนให้ทุกๆ… นาทีเอง สบายใจนั้งซดกาแฟ

สิ่งที่อยากแนะนำคือ เทคโนโลยีเปลี่ยนไปทุกๆวัน ทุกอย่างมีคุณและโทษ ถ้ารู้จักใช้ให้เป็นก็เกิดประโยชน์อย่างที่เห็นครับ และใครยังทำงานวงการนี้ ต้องวิ่งตามให้ทันครับ โลกมันเปลี่ยนตลอดเวลา เหมือนเทรนแฟชั่นเสื้อผ้าต่างๆ ครับ ยิ่งตามกระแสปัจจุบันท่าไรยิ่งขายดี

มาบ่นแค่นี้แหละครับ จริงๆ ospf ใช้กันระดับใหญ่ๆ แต่ก้มีระดับล่างหรือขนาดเล็กนำมาใช้บ้งแล้ว รู้ไว้ไม่เสียหายครับ

โพสท์ใน Mikrotik | ติดป้ายกำกับ , | 2 ความเห็น

Basic Failover Uninet By Mikrotik Netwatch

Capture

โพสท์ใน Mikrotik | ติดป้ายกำกับ , | แสดงความเห็น

Minihotspot1.2b for Mikrotik Ubuntu12

Original From Minihotspot1.2b Ubuntu10 By Guitar linuxthai
Mod by soravit

Download http://www.soravit.in.th/Minihotspot1.2b_MT_u12_soravit.zip

ถ้า เก็บ log ช้า ให้แก้ที่

By default rsyslog does a reverse dns lookup on every log that comes through. Simply disable the reverse lookup in rsyslog. The option to start rsyslog with is “-x” to disable dns lookups.

nano /etc/default/rsyslog

บรรทัด option..

เพราะ มันเสียเวลา resolve dns มาก

#กำหนดให้เรียก proxy ได้เฉพาะวงภายในเท่านั้น พิมคำสั่งใน mikrotik
/ip firewall filter
add chain=input in-interface= protocol=tcp dst-port=8080 action=drop

โพสท์ใน Mikrotik, Ubuntu | 2 ความเห็น

รับ Config Mikrotik Router

รับ Config Mikrotik Router ผ่าน Teamview ตามสั่ง ราคาถูกคุยได้ Email มาครับที่ soravit.m @ gmail.com

– Loadbalance Gateway 2-4 WAN PCC Method
– Static Routing / NAT
– Hotspot , Multiple Hotspot VLAN , Userman
– VLAN , Wireless
– DHCP Server
– Forward Port
– Web Proxy Mikrotik / Transparent Proxy
– Syslog Server Remote
– Mikrotik ทำเป็น Layer3 Switch
– Mikrotik คู่กับ IP จริงที่ได้จาก ISP
– VPN
– DDNS Client
– Queue
– รับติดตั้งและคอนฟิก Software KruComChan Mikrotik (ผลงานผมเอง) คู่กับ Mikrotik Router (Remoteเข้าไป)

ผลงาน
– Site www.bj.ac.th / Loadbalance 4 WAN + 2 Network Public IP + DHCP Server + 4 Static Routing

โพสท์ใน Mikrotik | แสดงความเห็น

KruComChan1.0 Mikrotik

KruComChan1.0 Mikrotik Radius User Management System (Single Mikrotik Router , Multiple hotspot vlan)

*** No Commercial Wi-Fi Hotspot Function , Implement on HighSchool , Office ***

Requirement:
Ubuntu 12.04 i386/amd64 server iso Server/PC
Mikrotik RouterOS 5.20 up Hardware Router or Server/PC

Software/Manual Download:
http://www.soravit.in.th/KruComChan1.0MT.zip

สอบถาม soravit.m @ gmail.com

ถ้า เก็บ log ช้า ให้แก้ที่

By default rsyslog does a reverse dns lookup on every log that comes through. Simply disable the reverse lookup in rsyslog. The option to start rsyslog with is “-x” to disable dns lookups.

nano /etc/default/rsyslog

บรรทัด option..

เพราะ มันเสียเวลา resolve dns มาก

#กำหนดให้เรียก proxy ได้เฉพาะวงภายในเท่านั้น พิมคำสั่งใน mikrotik
/ip firewall filter
add chain=input in-interface= protocol=tcp dst-port=8080 action=drop

10/7/2557

แก้ไขบั๊ค User_online
ดาวโหลดไฟล์และคู่มือแก้ไข http://soravit.in.th/KruComChanMT1.0_user_online.zip

โพสท์ใน Mikrotik, Ubuntu | 6 ความเห็น

Airlink(ฟรี!!) ทางเลือกสำหรับโปรแกรมควบคุม WiFi HOTSPOT

(หนึ่งในทีมผู้พัฒนา http://www.facebook.com/sartonice) Airlink พัฒนาต่อมาจาก minihotspot นะครับหลังจากที่ไม่มีคนพัฒนามานานมากแล้ว และก็มีบางคนนำมันไปปรับนิดๆหน่อยๆแล้วขาย ราคา 5-6 พัน ซึ่งผิดวัตถุประสงค์ของพี่ตาร์ซึ่งเป็นคนทำโปรแกรมนี้แต่แรก ผมกับพี่ๆจึงร่วมกันปรับปรุงมันใหม่ เป็น open source ให้ใช้ฟรีๆห้ามนำไปขายเด็ดขาด

#######
โปรแกรมทำงานบน ubuntu 10.01,12.04 และ ClearOS 5.2
#######
คุณสมบัติแอดมิน
-บล็อกบิต 100%
-สร้างบัตร ชั่วโมง,วัน,เดือน,เวลา,ตามข้อมูลที่ใช้ ต่อวัน เดือน ปี
-จำกัดความเร็ว ต่อคน/ ต่อกลุ่ม
-สร้างกลุ่มแพ็คเกจ
-กำหนดเวลาเข้าใช้งาน
-บล็อกเว็บ ความเร็ว ไฟล์
-สถิติแบนด์วิด รายได้ การเข้าใช้งาน
-สร้างจุดเชื่อมต่อ ประกาศหน้าแรก ป็อบอัพ ส่งข้อความ
-ผู้ใช้ออนไลน์ เตะผู้ใช้งาน ปล่อยผ่าน ให้รับไอพีใหม่
-อุปกรณ์ที่เชื่อมต่อ
-ตั้งค่า network,squid,advance cache
-ตั้งค่าระบบ
-สำรองข้อมูล
-จัดการไฟล์
-การใช้งานทรัพยากรระบบ live update
-ระบบ 2 ภาษา ไทย-อังกษฤ ตั้งค่าภาษาหลักได้
-อื่นๆอีกเยอะแยะ
-เติมเงินผ่านแอดมิน ผ่านบัตร
-เติมเงินผ่าน true money

####################
ส่วนผู้ใช้งาน
####################
-ประวัติการใช้งาน
-ประวัติส่วนตัว
-สมัครสมาชิก
-เลือกซื้อแพ็คเกจด้วยตัวเอง
-เติมเงินด้วย บัตร wifi,true money
-เปลี่ยนรหัส
-เคลียร์ session ด้วยตัวเอง
####################
User interface
####################
-responsive แสดงผลได้กับทุกบร๊าวเซอร์ 100%
-ธีมของระบบสวยงามน่าใช้ที่สุด
-ระบบตรวจสอบ user agent ที่สมบูรณ์แบบ
-ระบบอื่นๆที่ทำงานได้ดีอีกมากมายครับต้องลองใช้ดูเอง

#####################################################################

Airlink เปิดให้ดาวน์โหลดไปใช้งาน มีเพื่อนๆพี่ๆ ได้เอาไปใช้ในหน่วยงานราชการ ทหาร,โรงพยาบาล,โรงเรียน ซึ่งมีผู้ใช้งานพร้อมๆกันกว่า 600+ และใช้จริงในการให้บริการ wifi hotspot อีกหลายที่ครับทำงานได้ไม่มีปัญหา ดูคร่าวๆจากนี่ http://airlink-wifi.blogspot.com/ (น้องๆทำใว้ให้ครับ)
วิดีโอระบบ

#####################################################
ของฟรีไม่ต้องเสียเงินซื้อโปรแกรมแพงๆ ที่มีบริการซัพพอร์ตที่ยอดแย่ครับ เพื่อนๆที่เคยซื้อโปรแกรมดังๆ ของไทยหลายๆคนเปลี่ยนมาใช้ของฟรีกันหมดแล้ว เพราะที่นี่เวลามีปัญหาเราช่วยเหลือกันครับ รีโมทซัพพอร์ตให้กันและกันฟรีๆ ไม่มีค่าใช้จ่ายแก้ไขปัญหาให้ จนกว่าจะได้จริงๆ มีเพื่อนๆ พี่ๆ ที่ชำนาญ linux คอยพัฒนา kernel และ ระบบให้ใช้อีกด้วย การติดตั้งง่ายครับ สคริปติดตั้งให้ง่ายๆโดยที่เราแทบไม่ต้องมีความรู้ linux เลย

เข้าร่วมกลุ่มแล้วดาน์โหลดไปใช้งานได้ที่นี่ครับ https://www.facebook.com/groups/airlink.hotspot/

โพสท์ใน Ubuntu | ติดป้ายกำกับ , , , , | 8 ความเห็น

command gen FW Port dota + natloopback + auto public ip

command gen FW Port dota + natloopback + auto public ip
กด + Script นี้แล้วก๊อบวางใส่แล้ว run script 1 รอบ
{
:local ipnya
:set ipnya “192.168.1.” แก้ไอพีหน้าเครื่องลูก 192.168.1.
:local iprouternya
:set iprouternya 1
:local publicnya
:set publicnya “127.0.0.1”
:local portnya
:set portnya 6112 แก้พอร์ตเกม dota
:local startipnya
:set startipnya 20 เริ่มfwไอพีข้างในตั้งแต่เบอร์
:local endipnya
:set endipnya 30 ถึงเบอร์
:for i from=$startipnya to=$endipnya do={
/ip firewall nat add chain=srcnat src-address=($ipnya . “0/28″) dst-address=($ipnya . $i) protocol=tcp dst-port=($portnya) action=src-nat to-addresses=($ipnya . $iprouternya) to-ports=0-65535 comment=”$portnya”
/ip firewall nat add chain=dstnat dst-address=($publicnya) protocol=tcp dst-port=($portnya) action=dst-nat to-addresses=($ipnya . $i) to-ports=$portnya comment=”IP Public Dota”
:set portnya ($portnya + 1)}
}

Autochange public ip สำหรับเน็ตที่ไม่ได้เช่า public fix ip
กด + Script name dotaScript
ก๊อบวาง กด run script

:local addr [/ip address get [/ip address find interface=ใส่ชื่อinterfacepppoe] address]
/ip firewall nat set [/ip firewall nat find comment=”IP Public Dota”] dst-address=[:pick $addr 0 ([:len $addr]-3)]

ให้ Update ip ทุกๆ 10นาที ก๊อบวางคำสั่งใน Terminal
/system scheduler
add comment=”” disabled=no interval=10m name=CheckUpdateIP on-event=\
“/system script run dotaScript” policy=\
reboot,read,write,policy,test,password,sniff,sensitive start-date=jun/16/2010 \
start-time=12:00:00

credit
http://semutputlh.blogspot.com/2011/12/prototype-bnet-dota-menggunakan-ip.html

โพสท์ใน Mikrotik | ติดป้ายกำกับ | แสดงความเห็น

Script Block port scanner mikrotik

To protect the Router from port scanners, we can record the IPs of hackers who try to scan your box. Using this address list we can drop connection from those IP

in /ip firewall filter

add chain=input protocol=tcp psd=21,3s,3,1 action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”Port scanners to list ” disabled=no

Various combinations of TCP flags can also indicate port scanner activity.

add chain=input protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”NMAP FIN Stealth scan”

add chain=input protocol=tcp tcp-flags=fin,syn action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”SYN/FIN scan”

add chain=input protocol=tcp tcp-flags=syn,rst action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”SYN/RST scan”

add chain=input protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”FIN/PSH/URG scan”

add chain=input protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”ALL/ALL scan”

add chain=input protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list=”port scanners” address-list-timeout=2w comment=”NMAP NULL scan”

Then you can drop those IPs:

add chain=input src-address-list=”port scanners” action=drop comment=”dropping port scanners” disabled=no

Similarly, you can drop these port scanners in the forward chain, but using the above rules with “chain=forward”.

ref http://wiki.mikrotik.com/wiki/Drop_port_scanners

โพสท์ใน Mikrotik | ติดป้ายกำกับ | แสดงความเห็น