Mikrotik Loadbalance เน็ตสองเส้น (PPPoE+StaticIP) 1 LAN

Mikrotik Loadbalance For Home 1 LAN

Ether1=PPPoE From ISP Modem
Ether2=Fix IP From ISP Router
Ether3=HOMELAN

ตัวหนาสิ่งที่ต้องแก้

1.สร้างconnection pppoe,static ip สำหรับเน็ตสองเส้น (pppoe-out1,ether2)

2.สคริบแยกข้อมูลตาม wan ขาเข้าไปยัง mikrotik
/ip firewall mangle
/ip firewall mangle add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=ether1_conn
/ip firewall mangle add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn

2.สคริบแยกข้อมูลตาม wan ขาออกจาก mikrotik
/ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2

3.สคริบยอมให้ homelan เข้าไป network เดียวกันกับ ether2 ได้ (PPPoEไม่ต้อง)
/ip firewall mangle add chain=prerouting dst-address=พิมพ์networkของether2ลงไปและตามด้วยprefix action=accept in-interface=ether2

4.สคริบแบ่งน้ำหนัก Loadbalance แบบ PCQ แก้ไข เลข 4=จำนวนบรรทัดของ per-connection-class 0-4..ลำดับบรรทัดเริ่มจาก0 แบ่งตามอัตราส่วน เช่น เน็ต 10เม็กสองเส้น อัตราส่วนคือ 1:1 ดังนั้นออกเน็ต 1 ครั้ง และเน็ตที่สอง 1 ครั้ง
หรือ เน็ต20เม็ก 1 เส้น กับเน็ต 10เม็ก 1 เส้น อัตราส่วนคือ 2:1 ต้องออกเน็ตเส้นแรก 2 ครั้งแล้วออกเน็ตเส้นสอง 1 ครั้ง

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether3 per-connection-classifier=both-addresses-and-ports:ใส่เลขจำนวนบรรทัดperconnectionclass/0 action=mark-connection new-connection-mark=ether1_conn(ออกเน็ตเส้นที่สอง) passthrough=yes
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether3 per-connection-classifier=both-addresses-and-ports:ใส่เลขจำนวนบรรทัดperconnectionclass/1 action=mark-connection new-connection-mark=ether2_conn(ออกเน็ตเส้นที่สอง) passthrough=yes

5.สคริบแยกข้อมูลที่มาจาก wanต่างๆให้ออกตาม wanนั้นๆ โดยถูกต้อง
/ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether3 action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=prerouting connection-mark=ether2_conn in-interface=ether3 action=mark-routing new-routing-mark=to_ether2

6.Default Route สำหรับ ether2 Fix IP
/ip route
/ip route add dst-address=0.0.0.0/0 gateway=ไอพีRoutether2 routing-mark=to_ether1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_ether2 distance=1 check-gateway=ping

7.IPv4 NAT ตามจำนวน WAN
/ip firewall nat
/ip firewall nat add chain=srcnat out-interface=pppoe-out1 action=masquerade
/ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade

สำหรับ Internetแบบfix ip จะเช็คการ down โดย ping ไอพีrouterนั้นแต่กรณี internet ล่มจะเช็คไม่ได้ ให้เขียนสคริบเพิ่ม อ้างอิงตามนี้ http://www.soravit.in.th/wp/basic-failover-uninet-by-mikrotik-netwatch/

วิธีเอาคำสั่งไปรัน กด Terminal แล้วพิมพ์ใส่

** อีกวิธีนึงซึ่งมีภาพประกอบ แต่คล้ายๆกัน ของ ครูเก่ง
(2WAN PPPoE+StaticIPLoad-BalanceHotspot_PPPOEWan2)

เรื่องนี้ถูกเขียนใน Mikrotik และติดป้ายกำกับ คั่นหน้า ลิงก์ถาวร

2 ตอบกลับไปที่ Mikrotik Loadbalance เน็ตสองเส้น (PPPoE+StaticIP) 1 LAN

  1. อดิเรก พูดว่า:

    ลองทำตามแล้ว ใช้งานได้ดีครับ ขอบคุณสำหรับสคริปมากครับ

    อยากสอบถามเพิ่มครับ ถ้าในกรณีมีเน็ต fiber หรือ cable โมเด็มเป็นโหมด bridge จะตั้งค่า mikrotik ยังไงครับ

    ขอบคุณครับ

  2. Saran พูดว่า:

    ผมสงสัยครับว่าทำไมเราไม่ mark routing ใน rule เดียวกันกับ per connection classifier rule เลยครับ ทั้งๆที่มันก็อยู่ใน chain prerouting เหมือนกัน ทำไมต้อง mark connection ก่อน แล้วมา mark routing อีกที

    ผมลอง mark routing เลย โดยไม่ mark connection มันก็ได้เหมือนกันนะครับ

    /ip firewall add chain=prerouting dst-address-type!=local in-interface=LAN \
    per-connection-classifier=both-address-and-port:2/0 action=mark-routing \
    new-routing-mark=ISP1

ใส่ความเห็น

อีเมลของคุณจะไม่แสดงให้คนอื่นเห็น ช่องที่ต้องการถูกทำเครื่องหมาย *